New AppFurnace Player released for iPhone (1.40) & Android (1.1)

Follow

Comments

1 comment

  • Avatar
    tom

    Note: We now support Android 2.3.3 and above and iOS 5.x and above. 

     

    Thanks

    Tom

Please sign in to leave a comment.

Powered by Zendesk